Back to Blog home

Start with Qt 4.7 for Symbian, Today

Published on Sunday December 12, 2010 by aportale in Qt Quick Qt S60 | Comments

Did you always want to test your QML project on a Symbian phone but were held back, because there is currently no easy way to set up an environment with Qt 4.7 for Symbian? Then this post may be of interest. I'll show you a cheap trick how to set up Qt 4.7 for Symbian on top of the SDK 1.0 and without fighting through the traditional Symbian environment installation procedure.


Note: This is a cheap trick and it is not supported by Nokia. If you do not want to risk losing half an hour of time or if you prefer supported all-in-one installer solutions, please skip this and wait for the official release of the SDK with Qt 4.7 for Symbian. And Yes! We are sweating a lot to release the next SDK with Qt 4.7 for Symbian :). Good things take their time though, so right now there is still the SDK 1.0 with Qt 4.6 -no 4.7, no QML- for Symbian.

  1. Download and install the SDK 1.0
    Download the SDK 1.0 (you decide whether online or offline). Then launch the installer and run it in either Default mode (installs a lot!) or in Custom mode. If in Custom mode [screen shot], make sure that you leave at least the Symbian for Qt 4.6 component [screen shot] selected.
  2. Create a copy of the Symbian SDK and remove Qt 4.6 from it
    You should have a directory called <sdkdir>SymbianSDK. Create a copy of it like: <sdkdir>SymbianSDK-qt-4.7.1. Then delete Qt 4.6.3 from it, like this: (cd into the new SDK-qt-4.7.1, first)

    del /Q *
    del /Q /S epoc32releasearmv5q* epoc32releasearmv5phonon.*
    rd /Q /S bin include lib mkspecs src
  3. Download and install Qt 4.7 for Symbian
    For Symbian^1 and lower Download Qt 4.7.1 for Symbian and launch the installer.
    Edit: according to a comment, below, for Symbian^3, you need to Download Qt 4.7.0 for Symbian, instead.
    Choose Components step: select Symbian SDKs->Choose additional folder(s). [screen shot]
    Choose Install Location step: select a Destination Folder. I like to use <sdkdir>SymbianSDK-qt-4.7.1qt [screen shot], but you have a free choice as long as you stay on the same drive as the SDK.
    Select Symbian SDK directories step: set the root 1 directory to <sdkdir>SymbianSDK-qt-4.7.1. [screen shot]
  4. Install App TRK and Qt 4.7 on your Symbian device
    App TRK: you can find it under <sdkdir>Symbiansis. Install the one for your S60/Symbian version.
    Qt 4.7 for Symbian^1 and below: Install <sdkdir>SymbianSDK-qt-4.7.1qtqt_installer.sis
    Qt 4.7 for Symbian^3: Lucky owners of a Symbian^3 device can find a developer version of Qt 4.7 here.
  5. Add the new Qt version in Qt Creator
    Open Tools->Options->Qt4->Qt Versions and press on the + button. [screen shot]
    Version name: Your choice. I choose a completely unexpected "Qt for Symbian 4.7.1".
    qmake location: The qmake.exe which we installed in step 3. In my case: <sdkdir>SymbianSDK-qt-4.7.1qtbinqmake.exe
    S60 SDK: <sdkdir>SymbianSDK-qt-4.7.1
    CSL/GCCE directory: <sdkdir>Symbiangcce, The same gcce version directory which the preinstalled Qt 4.6 for Symbian has.
  6. (Optional) Install a Qt Creator snapshot
    Download a Qt Creator snapshot and install it. Optional, but definitely worth it!

That's it. Ahrgh, the instructions became longer than planned and look monstrous. But believe me: that it is nothing compared to the official manual setup of a Symbian environment. With the next SDK version, this instruction here will be of course obsolete, and the complete setup will just be a few mouse clicks of work.

Now enjoy your QML creations on Symbian phones! :)

Subscribe to Our Blog

Stay up to date with the latest marketing, sales and service tips and news.

We are updating our comment system and you could face some issues. Please write to us at feedback@qt.io to report issues/bugs.