3.15. The GNU Compatibility Matrix suggests that I cannot combine LGPLv2 and LGPLv3?

If LGPLv2.1 code and LGPLv3 code are in different shared libraries, then they can be used in the same application, and you can license your application with a proprietary license / LGPLv2.1 / LGPLv3 as you wish.