A memory corruption vulnerability in the QMqttClient class of the Qt MQTT module has been discovered and has been assigned the CVE id CVE-2026-107457.
Affected versions: from Qt 5.12.0 to Qt 6.8.8, from Qt 6.9.0 to Qt 6.11.2
Impact: Under certain MQTT 5 connection settings between client and server, QMqttClient may corrupt memory, which can cause the application to crash.
CVSS 4.0 Score: 2.3 / Low
Vector String: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/R:U/RE:L/U:Green
Mitigation: None.
Solution: Apply the following patch or update to Qt 6.8.9, Qt 6.11.3, Qt 6.12.0 or later.
Patches:
dev: https://codereview.qt-project.org/c/qt/qtmqtt/+/762286
Qt 6.11: https://codereview.qt-project.org/c/qt/qtmqtt/+/765308 or https://download.qt.io/official_releases/qt/6.11/CVE-2026-107457-qtmqtt-6.11.diff
Qt 6.8: https://codereview.qt-project.org/c/qt/tqtc-qtmqtt/+/765334 or https://download.qt.io/archive/qt/6.8/CVE-2026-107457-qtmqtt-6.8.diff