Resource exhaustion vulnerability in the HTTP request handling of the QHttpServer component of Qt HTTP Server has been discovered and has been assigned the CVE id CVE-2026-110944.
Affected versions: from Qt 6.4.0 to Qt 6.11.2, from Qt 6.12.0 to Qt 6.12.0
Impact: A remote, unauthenticated attacker could cause an application using QHttpServer to consume excessive memory, resulting in a denial of service (availability impact).
CVSS 4.0 Score: 2.7 / Low
Vector String: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/E:U/R:U/RE:L/U:Green
Mitigation: No mitigation is available at this time.
Solution: Update to Qt 6.11.3 or Qt 6.12.1 or later, or apply the following patches.
Patches:
Dev: https://codereview.qt-project.org/c/qt/qthttpserver/+/768560 https://codereview.qt-project.org/c/qt/qthttpserver/+/768934
Qt 6.12: https://codereview.qt-project.org/c/qt/qthttpserver/+/772619 https://codereview.qt-project.org/c/qt/qthttpserver/+/772752 or https://download.qt.io/official_releases/qt/6.12/CVE-2026-110944-qthttpserver-6.12-0001.diff and https://download.qt.io/official_releases/qt/6.12/CVE-2026-110944-qthttpserver-6.12-0002.diff