Skip to main content

Security advisory: CVE-2026-111487: Out-of-bounds write vulnerability in the assimp scene import plugin of Qt3D impacts Qt Framework

Comments
An out-of-bounds write vulnerability in the Qt Framework assimp scene import plugin of the Qt3D module has been discovered and has been assigned the CVE id CVE-2026-111487.
 
Affected versions: from Qt 5.9.0 to Qt 6.8.9, from Qt 6.9.0 to Qt 6.11.2, from Qt 6.12.0 to Qt 6.12.0
 
Impact: Importing a specially crafted 3D asset through the affected plugin may cause an application crash (availability) and may potentially affect memory integrity.
 
CVSS 4.0 Score: 4.3 (MEDIUM)
 
Vector String: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/R:U/RE:L/U:Amber
 
Mitigation: Do not import 3D asset files from untrusted sources with the Qt3D assimp scene import plugin.
 
Solution: Apply the following patches or update to Qt 6.8.10, Qt 6.11.3, Qt 6.12.1, Qt 6.13.0 or later. (Note: these versions have not been released yet.)
 
Patches:

Blog Topics

Comments

Comments are disabled for this post.

Subscribe to our blog

Try Qt 6.12 Now!

Download the latest release here: www.qt.io/download

Qt 6.12 LTS is now available, with new features and improvements for application developers and device creators.

We're Hiring

Check out all our open positions here and follow us on Instagram to see what it's like to be #QtPeople.